Optum Solution Status

System Incident - ACCUREG - ENGAGECARE PROVIDER - Production

Incident Report for Optum

Resolved

Eligibility processing is flowing as intended and automatic Audits and Estimations are working as expected.
Posted Jul 20, 2026 - 16:20 EDT

Update

Teams continue to troubleshoot and are making process to resolving the issue.
Posted Jul 20, 2026 - 15:43 EDT

Investigating

Teams are working to address the issues with Eligibility audits and estimates. EngageCare Provider customers are unable to process automatic audits and estimates for eligibility transactions.
Posted Jul 20, 2026 - 14:43 EDT
This incident affected: Patient Financial Clearance (EngageCare Provider).