Optum Solution Status

System Incident - CAC Professional - Production

Incident Report for Optum

Resolved

Optum technical teams have resolved the issue that caused users to experience latency issue while loading the documents in the Professional Computer-Assisted Coding. Optum technical teams will continue to monitor the stability of the system. Thank you for your patience as our teams worked to resolve this issue.
Posted May 20, 2026 - 03:28 EDT

Investigating

We are aware of an issue occurring within the Profession Computer-Assisted Coding application that is causing latency issue while loading the documents. Technical teams are engaged to resolve the issue and we will provide updates as more information becomes available.
Posted May 20, 2026 - 02:43 EDT
This incident affected: CAC Professional.