Optum Solution Status

System Incident - AHI QA & Lobby and Clearance Patient Access - Production

Incident Report for Optum

Resolved

Optum teams have deployed a fix, the Cloudflare issue is now resolved. Thank you for your patience as our teams worked to resolve this incident.
Posted May 26, 2026 - 16:17 EDT

Update

Optum is experiencing a performance issue with AHIQA and Clearance. This may result in users receiving an error message indicating user has been blocked along with a Cloudflare Ray ID number. Optum teams are working on a fix. We will provide an update as soon as possible.
Posted May 26, 2026 - 15:48 EDT

Investigating

We are aware of a potential issue occurring within AHI QA & Lobby and Clearance Patient Access. Internal support teams have been engaged to determine and resolve any impact. We will provide updates as more information becomes available.
Posted May 26, 2026 - 15:03 EDT
This incident affected: Patient Financial Clearance (AHI QA & Lobby, Clearance Patient Access).