Optum Solution Status

System Incident - MEDICAL NETWORK RELAY EXCHANGE - Production

Incident Report for Optum

Resolved

Functionality has been restored. Thank you for your patience as we worked to resolve the issue.
Posted May 07, 2026 - 12:15 EDT

Investigating

We are currently experiencing intermittent performance issues with ConnectCenter and Enrollment Central. As a result, the following processes may be impacted, including: real time eligibility, claim retrieval, claim validation, claim status and enrollments.

Our technical teams are actively working to resolve the issue, and we will provide updates as more information becomes available.

We sincerely apologize for any inconvenience this may cause and appreciate your understanding.

Action Required: No action is required at this time.
Posted May 07, 2026 - 11:05 EDT
This incident affected: Medical Network (Real Time).