Optum Solution Status

System Incident - MEDICAL NETWORK RELAY EXCHANGE - Production

Incident Report for Optum

Resolved

ConnectCenter functionality has been restored. Thank you for your patience and understanding.
Posted Jun 08, 2026 - 10:48 EDT

Update

We are still experiencing intermittent performance issues. Our development team continues to actively work toward full restoration.
Posted Jun 08, 2026 - 10:20 EDT

Investigating

We are currently experiencing intermittent performance issues with ConnectCenter. As a result, we are currently experiencing an error when performing searches in Payer Search, as well as when attempting to access claim links within Claim Search. Our technical teams are actively working to resolve the issue, and we will provide updates as more information becomes available. We sincerely apologize for any inconvenience this may cause and appreciate your understanding.
Posted Jun 08, 2026 - 08:34 EDT
This incident affected: Medical Network (Real Time).