Optum Solution Status

System Incident - : INTELLIGENT EDI CLEARINGHOUSE - Production

Incident Report for Optum

Resolved

Technology teams have restored access. Thank you for your patience as our teams worked to resolve this incident.
Posted Apr 30, 2026 - 13:17 EDT

Investigating

We are aware of a potential issue occurring within : INTELLIGENT EDI CLEARINGHOUSE . Internal support teams have been engaged to determine and resolve any impact. We will provide updates as more information becomes available.
Posted Apr 30, 2026 - 12:51 EDT
This incident affected: Medical Network (Batch).