Optum Solution Status

System Incident - MEDICAL NETWORK RELAY EXCHANGE - Production

Incident Report for Optum

Resolved

ConnectCenter functionality has been restored. Thank you for your patience as our teams worked to resolve this incident.
Posted Jun 02, 2026 - 11:46 EDT

Update

Functionality for Claim Healthcare Vitals and Payer Search has been restored. Our technical team is actively working to resolve the Claim Search not returning results issue. we will provide updates as more information becomes available.
Posted Jun 02, 2026 - 11:08 EDT

Investigating

We are currently experiencing intermittent performance issues with ConnectCenter. As a result, Claim Health Vitals not displaying, Payer Search not returning results, Claim Search not returning results.
Our technical teams are actively working to resolve the issue, and we will provide updates as more information becomes available.
We sincerely apologize for any inconvenience this may cause and appreciate your understanding.
Posted Jun 02, 2026 - 09:38 EDT
This incident affected: Medical Network (Real Time).