Optum Solution Status

System Incident - MEDICAL NETWORK RELAY EXCHANGE - Production

Incident Report for Optum

Resolved

The Real Time Claims Editing (RTCE) service has been restored as of 10:10 AM CT.

Thank you for your patience.
Posted May 26, 2026 - 11:56 EDT

Investigating

Exchange Real-Time traffic is experiencing issues this morning. From approximately 8:11 AM to 9:04 AM CT, about 6% of transactions were impacted. At this time, Eligibility and Claim Status are processing normally. Residual impact remains for RTCE, with full restoration expected before 11:00 AM CT.
Posted May 26, 2026 - 10:47 EDT
This incident affected: Medical Network (Real Time).