Optum Solution Status

System Incident - RCMFO Clearance - Production

Incident Report for Optum

Resolved

Technology teams have restored access. Thank you for your patience as our teams worked to resolve this incident.
Posted May 29, 2026 - 13:10 EDT

Update

Teams have identified a fix for the ongoing Estimate issue and plan to deploy it within the next hour. During deployment, users may experience brief connectivity disruptions, though this is not expected. Once deployment is complete and service stability is confirmed, a follow-up update will be provided.
Posted May 29, 2026 - 10:30 EDT

Investigating

Optum is experiencing performance issues with Estimator. This may result in users receiving ‘sorry, you have blocked error’ when accessing Estimator. We are working to resolve the issue and plan to implement a fix on Thursday, May 28th.
Posted May 22, 2026 - 12:53 EDT
This incident affected: Patient Financial Clearance (Clearance Patient Access).