Optum Solution Status

System Incident -OPTUM EFR PLATFORM - Production

Incident Report for Optum

Resolved

Updates have been made and performance is back to normal. Performance will continue to be monitored for a period to ensure there are no additional issues.
Posted May 18, 2026 - 10:57 EDT

Update

We are continuing to investigate this issue.
Posted May 18, 2026 - 10:56 EDT

Investigating

We are aware of a potential issue occurring within OPTUM EFR PLATFORM. Internal support teams have been engaged to determine and resolve any impact. We will provide updates as more information becomes available.
Posted May 18, 2026 - 09:02 EDT
This incident affected: eFR (eFR Legacy).