Technology teams have restored access. Thank you for your patience as our teams worked to resolve this incident.
Posted Jul 22, 2026 - 12:07 EDT
Identified
We are currently experiencing intermittent performance issues impacting the Assurance Reimbursement Management application.
Users may encounter: Difficulty logging into Assurance Delays or failures when loading claims General slowness while navigating the application
Our technical teams are actively investigating and working to restore normal performance as quickly as possible. Additional updates will be provided as more information becomes available.
Posted Jul 22, 2026 - 11:23 EDT
Investigating
Assurance Reimbursement Management is experiencing an issue with intermittent performance.
This may result: Inability to log into Assurance Unable to load claims Slowness when loading Assurance
Optum is working to resolve this issue. We will notify you as soon as additional information becomes available.
We apologize for any inconvenience.
Posted Jul 22, 2026 - 09:43 EDT
This incident affected: Revenue Cycle Management (Assurance Reimbursement Management).