Optum Solution Status

System Incident - AWS (Assurance Reimbursement Manager) - Production

Incident Report for Optum

Resolved

All services are now operating as expected, and phone and chat support are fully restored. Thank you for your patience while we resolved this issue. If you experience any further disruptions, please contact Support for assistance.
Posted Jun 02, 2026 - 14:21 EDT

Investigating

We are currently experiencing intermittent phone and chat outages. RCM Assurance (Assurance Reimbursement Manager) remains operational; however, support can only be accessed through the Customer Care Hub at this time.
Posted Jun 02, 2026 - 11:25 EDT
This incident affected: Revenue Cycle Management (Assurance Reimbursement Management).