Optum Solution Status

System Incident - RCM ASSURANCE - Production

Incident Report for Optum

Resolved

This issue has been resolved. Performance has returned to optimal levels. Support will resume all impacted jobs for hosted clients. For Turnkey clients, please resume any failed jobs. If you have any questions, please contact Support.
Posted Jun 04, 2026 - 17:29 EDT

Investigating

We are aware of a potential issue occurring within RCM ASSURANCE. Internal support teams have been engaged to determine and resolve any impact. We will provide updates as more information becomes available.
Posted Jun 04, 2026 - 15:51 EDT
This incident affected: Revenue Cycle Management (Assurance Reimbursement Management).