Optum Solution Status

System Incident - Medical Network Portal - Production

Incident Report for Optum

Resolved

ConnectCenter functionality has been restored. Thank you for your patience while the issue was being resolved.
Posted Jul 28, 2026 - 17:01 EDT

Update

Teams continue to investigate. We will provide our next update in approximately one hour.
Posted Jul 28, 2026 - 16:22 EDT

Investigating

We are currently experiencing an issue that is preventing users from accessing ConnectCenter functionality. Our technical teams are actively investigating and working to restore service as quickly as possible.
Posted Jul 28, 2026 - 16:11 EDT
This incident affected: Medical Network (Portal).