Optum Solution Status

System Incident - Revenue Performance Advisor - Production

Incident Report for Optum

Resolved

Functionality has been restored. Thank you for your patience as we worked to resolve the issue.
Posted May 07, 2026 - 13:13 EDT

Investigating

We are currently experiencing intermittent performance issues with Real Time Eligibility and Claim Status. Our technical teams are actively working to resolve the issue, and we will provide updates as more information becomes available. We sincerely apologize for any inconvenience this may cause and appreciate your understanding.
Posted May 07, 2026 - 11:36 EDT
This incident affected: Revenue Performance Advisor.