Resolved: This issue has been resolved. Performance has returned to optimal levels.
Original notify sent on: 6/4/2026: Assurance Reimbursement Management is experiencing an issue with intermittent performance.
This may result in:
• Error: Page not found when attempting to export assignments to CSV • Slowness or partial screen display in viewing assigned claims in the Operations Dashboard
Optum is working to resolve this issue. We will notify you as soon as additional information becomes available.
We apologize for any inconvenience.
Action Required: None.
Posted Jun 12, 2026 - 13:46 EDT
Investigating
Assurance Reimbursement Management is an issue with intermittent performance.
This may result in:
• Error: Page not found when attempting to export assignments to CSV • Slowness or partial screen display in viewing assigned claims in the Operations Dashboard
Optum is working to resolve this issue. We will notify you as soon as additional information becomes available.
We apologize for any inconvenience.
Action Required: None.
Posted Jun 08, 2026 - 14:40 EDT
This incident affected: Revenue Cycle Management (Assurance Reimbursement Management).