Optum Solution Status

System Incident - ACCUREG - ENGAGECARE PROVIDER - Production

Incident Report for Optum

Resolved

The EngageCare Eligibility (EV) services are restored. A backlog is present and currently processing through, it's estimated the backlog will be clear in two hours.
Posted Apr 27, 2026 - 23:03 EDT

Investigating

The EngageCare Eligibility (EV) services are currently experiencing a processing issue. Teams are engaged to resolve the issue.
Posted Apr 27, 2026 - 22:05 EDT
This incident affected: Patient Financial Clearance (EngageCare Provider).